Retrun code 255 is out of bounds, wierd issue with a single


#1

Hello,

I have a box who’s service checks in the web browser are showing “CRITICAL (Return code of 255 is out of bounds)”. If i run the check_by_ssh commands from the server to this box it always returns ok with all the proper data. I can run it over and over and still it returns proper. If i run the commands directly on the client it also returns with the proper code and information. It also appears that after 10 checks or so 1 or more of the service checks will return the proper info in the web browser, then on the next check back to failure.

Has anyone seen this before? anyone have a clue on where i can begin trouble shooting?

Thanks, Alan


#2

Sounds like a weird one. might not be applicable, but are you running your plugins as a different user (ie: nagios user)? have you tried switching to your nagios
user and then running the exact commands from your checkcommand definitions (but replacing the macros with the proper values)?

You should also try tailing /var/log/secure on the remote box to see if it’s generating an error when nagios runs check_by_ssh on that host

other than that…just googled the problem and some other people seem to be having the same problem. heres one of the links i saw:
mail-archive.com/nagios-user … 18645.html

have you considered nrpe instead of check_by_ssh :wink: ?