Running Configuration Check... FAILED!


#1

Hello,

I have been using nagios (netsaint really) for years and recently we decided to upgrade the server etc. You know the deal, basically it has been years and I am reinstalling and the new version is throwing me off.

I tried so far to create all the hosts services contacts etc. I believed I had set it up all right but got this when I tried to start:

Running Configuration Check… FAILED! Check you r Nagios Configuration.

Is this the nagios.cfg file or just everything? Is there a way to find out more information about what it does not like?

Thank you in advance for your ideas and help :slight_smile:


#2

I bet the problem you are running into is you’re attempting to use the /etc/init.d/nagios script to start it. That is typically OK, but it looks like that script is throwing away the output you are looking for. I think you can simply execute the Nagios binary, passing a “-v” and the path to the nagios.cfg file. This will run a “Verify” and give you the output you’re missing.

So for example, you’d run this: /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

The output you get should give you a clue as to where your problem is. If not, post it to this thread.


#3

Thank you very much !!! You are correct, I was trying service nagios start - I should have thought of the wya you suggested :wink:

Many many thanks!


#4

Once you get Nagios to verify correctly, then you should go back to using ’ service nagios start ', or ’ /etc/init.d/nagios start '. Executing ’ nagios -v nagios.cfg ’ should just be a short-term workaround while you get your configuration files straightened out.