Scheduler doesn't execute check



I have problem with Nagios 3.0.6. The nagios is configured to process performance data via NagiosGrapher.

From time to time one service is not regullarly executed. The scheduling queue is correct,
the service is included in it in right way, but the check command is not executed anymore.

The strange things are, that I have several similar services, which are ok. And the problematic service
had been ok for serveral months before. The configuration was not change, eventhough the nagios was not restarting
while the problem occured.

I tried to restart nagios, nagios grapher and reschedul the problematic service, but with no success.
I found recommendation on this forum to change service_perfdata_file_mode to w, but this doesn’t help too.

Does anybody have any other idea how to correct this mistake?



Have you tried to check the service from terminal? What output do you get. Try to simulate the situation from the command line so we could see what problem are you experiencing.

What does nagios.log say?