Service Command Issue [CENTOS 5.4 NAGIOS 3.2.1]


#1

First and foremost I am new to Nagios and my Linux skills are rusty.

I have Nagios installed and working. I’ve defined a number of hosts groups and have it monitoring our servers/switches/routers successfully. However, when I click on a warning and try to issue a service command i get the following error.

Error: Could not stat() command file '/usr/local/nagios/var/rw/nagios.cmd'! The external command file may be missing, Nagios may not be running, and/or Nagios may not be checking external commands. An error occurred while attempting to commit your command for processing.

I’ve searched all over looking for a solution, but none have worked. The latest solution I tried can be found here http://nagios.sourceforge.net/docs/2_0/commandfile.html

Please help!

[root@TLC-NAGIOS nagios]# id nagios uid=500(nagios) gid=500(nagios) groups=500(nagios),502(nagiocmd) context=root:system_r:unconfined_t:SystemLow-SystemHigh

[root@TLC-NAGIOS etc]# ls -al /usr/local/nagios/var
total 576
drwxrwxr-x 5 nagios nagios   4096 Jun  8 04:17 .
drwxrwxr-x 9 nagios nagios   4096 Jun  3 09:01 ..
drwxrwxr-x 2 nagios nagios   4096 Jun  8 00:00 archives
-rw-r--r-- 1 nagios nagios      6 Jun  8 03:26 nagios.lock
-rw-rw-r-- 1 nagios nagios  26971 Jun  8 03:42 nagios.log
-rw-r--r-- 1 nagios nagios 114613 Jun  8 03:26 objects.cache
-rw------- 1 nagios nagios 182248 Jun  8 03:26 retention.dat
drwxrwsr-x 2 nagios nagios   4096 Jun  8 03:26 rw
drwxrwxr-x 3 nagios nagios   4096 Jun  3 08:12 spool
-rw-rw-r-- 1 nagios nagios 182138 Jun  8 04:17 status.dat

Thanks in advance and let me know if you need to see any of my config files.


#2

did you install an RPM or from source?
if from source you probably missed “make install-commandmode”.


#3

I already ran that, same error. However, I didn’t run it until after I started configuring Nagios and stumbled across it on my search.

Here is the guide I followed http://www.kernelhardware.org/install-nagios-on-centos-5/