Service definition record not sent to ndomod


#1

Hello,

I have a peculiar problem with Nagios - Ndoutils - centreon.

WIth the sample configuration in the installation, everything works fine. Nagios reports the Hosts and Services as OK and shows up correctly in the web interface. The records are sent correctly to ndomod and shows up in centreon interface. The fields is_active in the table nagios_objects for the services are set to 1 correctly. Looked at the code and a record (host definition for hosts and service definition for services) is sent to ndomod which is set by ndo2db in the database.

The problem starts once I export the configuration from centreon.

Nagios shows no problems with the configuration and starts correctly. In nagios, the web interface shows the hosts as UP and services as OK (just 4 services monitoring localhost). All correct so far. However, only the host definition record is being sent to ndomod and not the Service Definition records. The result is that while nagios shows everything as UP/OK, centreon shows the services as disabled (since the field is_active = 0 in the ndo database table nagios_objects).

For some reason, the configuration exported by centreon causes nagios not to send the Service Definition record but sends other records after service checks. I have looked at the configuration and tried comparing to the sample config and cannot find any problems. I have also taken the default and working nagios.cfg and replaced only the configuration files for the hosts/services… generated by Centreon. Same result.

Any pointers on where to look or what to look for. I can upload the configuration files generated if needed.

Please Help! Thanks!