Service notifications lost when host down with nagios 1.2


#1

Hi!
Sorry for the title, but I couldn’t find a way to sum up the problem, so here we go:
The problem is shown in the attached screenshot and is the result of the following:
-A service goes down
-A host goes down
-The host goes up. Nagios sends a host up notification
=> the service up notification is never sent, meaning that the alarm triggered by this service is never cleared.

So, the questions are:
-is there a way to correct this with nagios 1.2 ?
-is this problem solved with newer versions (plzzzz, say yes: I could convince my chiefs to upgrade our old version :))
-do you know anything else that could help me with this problem ?

Thanks in advance


#2

Hi!

sorry to reply to my own post…
but I really really need some help on this issue:
Currently, we are sending notifications, but no recoveries.

Plz tell me someone has some information on this subject, or anything related

Thx in advance, and don’t hesitate to ask further questions if you need more info on our configuration.
(and don’t hesitate to reply if you know anything related to this issue)


#3

the service will not return to an OK state until nagios receives an OK state on its next round of checks. If nagios is receiving service check results for that service that say OK (tail your nagios.log) and it’s still not updating its status, then thats just messed up!
it could be a couple things that i totally wouldn’t bother with, cause i would just update. Nagios 3.0a5 is out for crying out loud, upgrade your version!!! 2.9 is the latest stable version, is better looking, more features, more community plugins, and works great! Theres so many threads with people “hi i am running 1.x nagios…” , update already! :slight_smile: