forums.meulie.net

Snmp config error

Hi all,
I’m trying to configure snmp for nagios to be able to monitor system resources on Fedora core 3 using net-snmp-5.1.2-11 version. when I ran ./check snmp on the nagios system I got the result:
SNMP problem - No data recieved from host.

when I ran the command:

I get the followin error:

[root@web0 ~]# snmpget -v 1 -c public -H localhost system
Configuration directives understood:
No log handling enabled - turning on stderr logging
In snmp.conf and snmp.local.conf:
doDebugging (1|0)
debugTokens token,token…]
logTimestamp (1|yes|true|0|no|false)
mibdirs [mib-dirs|+mib-dirs]
mibs [mib-tokens|+mib-tokens]
mibfile mibfile-to-read
showMibErrors (1|yes|true|0|no|false)
strictCommentTerm (1|yes|true|0|no|false)
mibAllowUnderline (1|yes|true|0|no|false)
mibWarningLevel integerValue
mibReplaceWithLatest (1|yes|true|0|no|false)
printNumericEnums (1|yes|true|0|no|false)
printNumericOids (1|yes|true|0|no|false)
escapeQuotes (1|yes|true|0|no|false)
dontBreakdownOids (1|yes|true|0|no|false)
quickPrinting (1|yes|true|0|no|false)
numericTimeticks (1|yes|true|0|no|false)
oidOutputFormat integerValue
suffixPrinting integerValue
extendedIndex (1|yes|true|0|no|false)
printHexText (1|yes|true|0|no|false)
printValueOnly (1|yes|true|0|no|false)
dontPrintUnits (1|yes|true|0|no|false)
dumpPacket (1|yes|true|0|no|false)
reverseEncodeBER (1|yes|true|0|no|false)
defaultPort integerValue
defCommunity string
noTokenWarnings (1|yes|true|0|no|false)
noRangeCheck (1|yes|true|0|no|false)
persistentDir string
tempFilePattern string
noDisplayHint (1|yes|true|0|no|false)
16bitIDs (1|yes|true|0|no|false)
clientaddr string
defSecurityModel string
defSecurityName string
defContext string
defPassphrase string
defAuthPassphrase string
defPrivPassphrase string
defVersion 1|2c|3
defAuthType MD5|SHA
defPrivType DES (AES support not available)
defSecurityLevel noAuthNoPriv|authNoPriv|authPriv
In snmpapp.conf and snmpapp.local.conf:
engineID string
engineIDType num
engineIDNic string
[root@web0 ~]#

My snmp config file is still on default settings just wanted to test if snmp was working properly before I configure.

thanks

I’m sure there are many sites on the net that explain how to setup a snmpd. From the output of your check_command, it looks like it’s not even running on localhost.

I have searched the internet on how to setup snmpd and tried all the ones that I found but still got the same error…

when I run the command /etc/snmp/snmpd restart after every change it shows ok and when I run the command it still gives the same error

Hi,
I just realised my mistake I was actually adding the -H option to the snmpwalk command I guess that was my error!!!
Thanks