Solaries and NRPE


#1

currently we are running a Linux system, with nrpe 2.51, and attempting to get a solaris client running 1.9.

I have gotten it installed, and running in daemon mode. When I run a check locally (check_load -w 15,10,5 -c 30,25,20) I get a positive response. Happy system.

When I switch to the linux server, and run ./check_nrpe -H x.x.x.x -n -p 5666 -c check_load I get a time out, a referance to check server logs, and the server shows: “Jun 13 12:04:50 spstest01 nrpe[11196]: [ID 421412 daemon.error] Could not read request from client, bailing out…”

The pluasible causes that rather leap out at me are…

Version issues (is the versioning the same between Solaris and Linux?)

Evil space monkeys.

Ok, I doubt it is the monkeys, but I am rather stuffed on what it could be. I generally take the tactic of figure out what is broke and then fix it, but the only issue I can see is “I can’t understand the request”.

Any pointers? Any info on where to get a current version?

Thanks,

–L


#2

…not clear from your message, is the version of check_nrpe on the nagios server the same as the version of nrpe on the remote client? They have to be the same version or most likely it will not work.


#3

Ok, to clarify, the versioning didn’t match, so I got the newest source, compiled it (eventually giving up entirely on SSL for now) and it works fine from the command line. However. The server still has it red flagged and the problem appears to be that I need to re-flag the command to have the server not attempt ssl for this client.

So, the question now is, is there a way to turn off ssl for just one client, or do I need to re-compile the server side and turn off ssl?


#4

Yes, if you do not want to use ssl on either side, with nrpe-2.5.1 you can use the -n qualifier with either check_nrpe on the server side, or nrpe on the remote system.

If the remote system was built and configured without ssl, you can define a separate entry in checkcommands.cfg on the nagios server as in the following example:

define command{
command_name check_nrpe_no_ssl
command_line $USER1$/check_nrpe -n -H $HOSTADDRESS$ -p 5666 -t 180 -c $ARG1$
}

(note the -n qualifier in the command_line) modify your service check (in services.cfg) to use check_nrpe_no_ssl and restart the nagios server


#5

I realised I had a versioning error, so now I am off down the rathole of trying to get 2.5.1 to compile on my solaris server…

Once I have that resolved, maybe then things will work.

–L