[SOLVED] nagiosgraph again


#1

Running nagios 3.2.0 + nagiosgraph 1.3.2

I tried following the (few) instructions in the INSTALL file distributed with nagiosgraph and i’m now stuck…

here’s what i have.

/usr/local/nagios is the default nagios install
nagsiograph files are in /usr/local/nagios/nagiosgraph
insert.pl and insert.sh are in /usr/local/nagios/lib

I’m trying to graph only localhost load for the beginning

not sure what went wrong but after some tests i got insert.pl to be run very 30 seconds, problem is it tells me (in nagiosgraph.log)

insert.pl warn - perfdata not recognized: servicedescr:$
output:$
perfdata:$

content of service perfdata is:

1258812035||localhost||Current Load||OK - load average: 0.00, 0.02, 0.00||load1=
0.000;5.000;10.000;0; load5=0.020;4.000;6.000;0; load15=0.000;3.000;4.000;0;

the map file is default:

# Service type: unix-load
#   output: OK - load average: 0.66, 0.70, 0.73
#   perfdata:load1=0;15;30;0 load5=0;10;25;0 load15=0;5;20;0
/output:.*load average: (.0-9]+), (.0-9]+), (.0-9]+)/
and push @s,  'load',
                'avg1min',  GAUGE, $1 ],
                'avg5min',  GAUGE, $2 ],
                'avg15min', GAUGE, $3 ] ];

if i click on the graph icon in the services page i only get:

Nagiosgraph has detected an error in the configuration file: /usr/local/nagios/nagiosgraph/nagiosgraph.conf.
/usr/local/nagios/nagiosgraph/rrd is empty

rrds are obviosuly not created.
Any ideas?

Thanks.


#2

Got this one too…

the perflog (in nagiosgraph.conf) and service_perfdata_file have to be the same file.
I missed the note when installing…

i’m now getting something created when clicking on the graph icon (looks like showgraph isn’t working yet) but the RRDs are created :slight_smile: