Somethins... wrong


#1

aight so I cant figure out how to fix this up… everything is running without error EXCEPT for one configuration somewhere and I cant find it for the life of me… here’s the hint that I have from the server error logs:
on Feb 27 16:12:54 2006] [error] [client 70.17.2.2] File does not exist: /home/nagios/public_html/home/nagios/public_html/cgi-bin/avail.cgi
[Mon Feb 27 16:12:54 2006] [error] [client 70.17.2.2] File does not exist: /home/nagios/public_html/404.shtml

got a bunch of those… for some reason, it’s loading the path twice… I dont know where to fix. btw, that log example applies to every cgi script there.

Any help on this issue would be great as we’re trying to launch soon. :smiley:


#2

ok i redid it all and i’ve run into the problem described in the nagios FAQ @ nagios.org/faqs/viewfaq.php?faq_id=43

thing is… i dunno how to “recompile without debugging enabled” as i cant find it anywhere in the docs and, well, when i compiled what’s there now, i didn’t use any extra parameters. followed the instructions to the T


#3

that doesn’t look to me as the problem described in that FAQ article…
I’d start checking in resource.cfg to see if the paths are all ok… if all else fails make a backup of the cfgs and do a make install-config to get the orignal config files… and mak e acouple of replacemnts for testing…

Strangest part of all is that it all works…

Luca


#4

the problem described in the very first post no longer applies… I now have the problem described in the faq regarding premature end of script etc. etc.


#5

Is selinux running on your machine? I had to disable this.


#6

How do i check? i’m not experienced at all with selinux…


#7

The premature end of script headers is completely different from the “malformed headers” to which that link refers.

You’re not running a Fedora distro on your Nagios box by any chance, are you? I’ve noticed this problem is common with the SELinux policy for allowing CGI’s to be run in Apache.


#8

CentOS…


#9

I’ll attempt to answer your latest problem, but only after I find out what was done to fix your first problem. Call it curiousity or call me anal, or call me an ##$$%. But anyway, your solution may help others.


#10

Ah, CentOS…still RH-based. Mayhap my fix will still work.

Anywhos, I don’t think he actually fixed it at all. I believe he just re-did the install and now has a new problem.


#11

i reinstalled :wink: never actually fixed it…

what’s your fix? i just wanna get this thing working asap. my boss is really needin it…


#12

He wants you to turn off your selinux firewall. I run centos also, and that is what I did.


#13

how? i know nothing about selinux lol


#14

/usr/bin/system-config-securitylevel or click on the shortcut made in your gnome/kde menu that says “Security level”


#15

ok that brought up a window that says:

A firewall protects against unauthorized network intrusions. Enabling a firewall blocks all incoming connections. Disabling a firewall allows all connections and is not recommended.

it’s been disabled… any other ideas?


#16

Your apache error log might give us more needed information. Take a good look at it.


#17

meulie.net/e107_plugjes/foru … pic.php?63
So what is your problem exactly anyway? I still haven’t seen any description of it. Just a mention about a faq, that you gave no link to.


#18

meulie.net/e107_plugjes/foru … ic.php?366
meulie.net/e107_plugjes/foru … ic.php?711


#19

[Wed Mar 8 12:52:04 2006] [error] [client 70.17.2.2] Premature end of script headers: /usr/local/nagios/sbin/status.cgi

buttload of those in the apache error log. every page that uses a cgi logged into nagios come up with the dreaded “internal server error”


#20

Try running this command:

chcon -R system_u:object_r:httpd_sys_script_exec_t /usr/local/nagios/sbin

See if that fixes anything.