Status Information (null


I have problem with check_oracle_generic. It work’s good when I execute it from command line. But in Nagios t returned Critical and Status Information is (null). Any Ideas?


Could you post a few lines of your config files so that we may have some ideas ? :slight_smile:


Hmm in my command file I have:
define command {
command_name check_oracle_generic
command_line $USER1$/check_oracle_generic -SID=$ARG1$ -dbuser=$ARG2$ -dbpassword=$ARG3$ -w=$ARG4$ -c=$ARG5$ -q=$ARG6$

I was searching about this even on germany forum and I have tried to -q="$ARG6$"

In my services config I have :


I’ ve tried something like this: select count(*) from v$/$table_name … but the status information was null:( Thanks very much for help;)


Hey Ania,

Sounds like nagios is getting confused trying to pass special characters in your query input.

In your service command, try escaping some of the special characters in your “query” with . eg:

“select count(*) from v$/$table_name”

If that doesn’t work, im not sure how much you need your query command to be contained in your nagios configs… if possible, you could always make your own little script

vi /opt/

/usr/local/nagios/libexec/check_oracle_generic -SID=sid -dbuser=user -dbpassword=password -w=1 -c=2 -q=“select count(*) from v$/$table_name”

define command {
command_name my_check_oracle
command_line /opt/

then in services
checkcommand my_check_oracle

Those would be your two options, unless someone else has another idea.


Thanks very much for answer! The second option doesn’t working… of couurse it works from command line;] But I’m still keep trying with
"some of the special characters in your “query” with . " :frowning: Greetings