Statusmap.cgi not compiling


#1

opensuse 10.2.
nagios version 2.7

I have everything working that I’ve tried so far, but. The status map link gives an error Object not found.

Found that I didn’t have the libgd installed so I have installed it and tried to redo the make commands and the cgi (and a few more) isn’t compiled/installed. The make commands don’t even seem to be trying to compile the statusmap.c, at least I don’t see it.

any idea??

Thanks for the help


#2

more info:
following the Nagios FAQ on status map CGIs, this is the error from make all.

gcc -g -O2 -I/usr/local/include/ -DHAVE_CONFIG_H -DNSCGI -L/usr/local/lib/ -o st atusmap.cgi statusmap.c getcgi.o cgiutils.o cgiauth.o objects-cgi.o xobjects-cg i.o statusdata-cgi.o xstatusdata-cgi.o -lgd -lttf -lpng -ljpeg -lz -lm
/tmp/ccQJAY1X.o: In function load_image_from_file': /usr/local/src/nagios-2.7/cgi/statusmap.c:2215: undefined reference togdImageC reateFromJpeg’

collect2: ld returned 1 exit status
make[1]: *** [statusmap.cgi] Error 1
make[1]: Leaving directory `/usr/local/src/nagios-2.7/cgi’
make: *** [all] Error 2


#3

Just so its in the archive.
The graphic libs are installed on opensuse in /usr/local/lib. I had to make a link from /lib so the statusmap could find them.