Statusmap.cgi not found


#1

Hi All,

I installed the png, jpeg and zlib libraries on /usr/local/include and configuring the nagios with all the libraries but get the following message

checking for main in -liconv… no
checking for gdImagePng in -lgd (order 1)… no
checking for gdImagePng in -lgd (order 2)… no
checking for gdImagePng in -lgd (order 3)… no

*** GD, PNG, and/or JPEG libraries could not be located… *********

and so statusmap.cgi does not get created in the sbin directory. Do I need any other libraries other than 3 that is mentioned. Looks like I am missing some dependencies.


#2

you need
libgd, libgd-devel, linpng, libpng-devel, libjpeg, libjpeg-devel, zlib, zlib-devel.
I also needed to add freetype to get it working…

Then

make devclean
configure
make all

let me know how it goes…

G


#3

I can’t seem to find the devel packages for FreeBSD though. Has anyone installed the devel packages for FreeBSD?


#4

not running BSD but Solaris… and i finally got my GD working again after months of clueless stumbling around.

I don’t know if BSD has some sort of “dependency aware” installer like apt-get for debian or pkg-get for solaris… if you have something like that use it to install the gd package so you will have all dependencies solved.
Solving them “by hand” is somthing like suicide (at least for me :smiley: )

You mean the GD-Devel packages? try at the gd homepage. boutell.com/gd

Luca


#5

hi
I installed and configured nagios 2.0 on linus SME server. it works right but on /nagios/sbin, I didn’t find statusmap.cgi.
should i install the librairies and this statusmap.cgi will be installed automaticaly on /nagios/sbin oe should I install librairies and reinstall nagios.

Thanks for any help you can provide

Regards.


#6

If you are speaking about the gd libs, then yes, install the gd libs, recompile and then install nagios.


#7

hi
I compiled and installed
- jpegsrc.v6b.tar.gz
- xpm-3.4k-linux.tgz
- zlib-1.2.3.tar.gz
- freetype-2.1.10.tar.bz2
to /usr/lib
then I compiled and installed gd-2.0.33.tar.gz
then I tried to compile and install nagios 2.0. when I compil with make all, I have the followinf error

gcc -g -O2 -DHAVE_CONFIG_H -DNSCGI -o statusmap.cgi statusmap.c getcgi.o cgiutils.o cgiauth.o objects-cgi.o xobjects-cgi.o statusdata-cgi.o xstatusdata-cgi.o -lgd -lz -lm -lpng
/tmp/ccPYttv3.o(.text+0x3bfe): In function load_image_from_file': /usr/local/src/nagios-2.0b4/cgi/statusmap.c:2216: undefined reference togdImageCreateFromJpeg’
collect2: ld returned 1 exit status
make[1]: *** [statusmap.cgi] Error 1
make[1]: Leaving directory `/usr/local/src/nagios-2.0b4/cgi’
make: *** [all] Error 2

Thanks for any help you can provide

Regards.


#8

You most likely made the same mistake I did with gd.
Please follow the adivice in the gd docs here.
boutell.com/gd/manual2.0.33.html

UPGRADING UNIX USERS: READ THIS FIRST! Modern versions of gd install by default to /usr/local/lib and /usr/local/include. If you already have an older version of gd in /usr/lib and /usr/include, you may wish to use:

./configure --prefix=/usr

To ensure that your new installation overwrites the old.


#9

[solved]
the jpeg librairie must be shared. complil with enabled-shared option.