Su: /bin/bash: Permission denied


#1

When I try to start nagios I keep getting te following error message;
/etc/init.d/nagios start
su: /bin/bash: Permission denied
PID TTY TIME CMD
943 ? 00:00:00 nagios

localhost/nagios
internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Steps taken;

  • nagios -v /etc/local/nagios/etc/nagios.cfg
    no error reported

chmod 777 /etc/local/nagios
nagios user has full permission to directories…etc.

Any successions?

Thank you.
ddemirchi


#2

Have you changed permissions on the Nagios startup script? Also, check nagios.log and see what comes up. Are you attempting this as root or the Nagios user?


#3

chmod 777 /etc/local/nagios isn’t going to work.
at least you need chmod -R 777 but it would really be better to leave itas it has been installed as most permissions are already set.


#4

The above indicates that the init script was not able to su -l $Nagios. Look at the init script to see more details and then try to execute the command by hand as nagios user. It also shows that nagios has started with pid of 943.
Edited Thu Feb 02 2006, 06:27PM ]


#5

Follow the docs on how to setup apache again.


#6

I had that problem a while ago with not being able to su to users…it was after I’d messed with permissions on their home directories. I wonder if that’s the issue here…


#7

Well, on Solaris “su -l nagios” is not a legal switch option, but in linux it is, so you would have to modify the init script to suit your OS. Try it.


#8

“su -l nagios”

this WILL be recognized correctly by configure…
i was using nagios on solaris up to a month ago and had not had problems during install, so it shouldn’t really be there if it has been compiled on the correct machine…

(well yessss, ok, GD was a PITA but that’s another story :smiley: )

Luca