Trend and Availability reports only show history back to Mon


#1

I’ve been using Nagios for several months now and I’m just starting to get to using the reporting features more heavily. One thing that I’ve run into is that anytime I do any kind of report, the data only goes back to the Monday of the current week, and there is no data from any previous time periods. Of course if I try to specify the initial state, it will report the “missing” time as whatever I set the state to (ie. OK, Warning, etc), but that isn’t accurate, and its just filling in the time with what I’m telling it to assume.

I’ll need to do reports for each calendar month, but since the history available in my reports resets each Monday, I can never do more than up to 7 days of accurate reporting at a time. From the research I’ve done, it sounds like Nagios should be reading the archived log files that have been compressed, but it looks to me as if that is just not happening. I’ve spent a good deal of time doing Google searches and I haven’t come any closer to figuring this out, so any nudges or info will be very helpful.


#2

[blockquote]…reading the archived log files that have been compressed[/blockquote]
How are your archived logfiles compressed? I can’t find any option to turn on log compression in the config file, only turning rotation on and setting the log rotation period… If you are using some external logrotate function to compress them that I suppose that’ll be why nagios can’t read them back in.


#3

I found the answer to this. There is a cron.weekly file automatically set up with the nagios install when done through YaST in OpenSuSe 11. I found this:

[code]nagios:/etc/cron.weekly # cat suse.de-nagios
#!/bin/sh

Compress old nagios logfiles in /var/log/nagios/archives/

once a week, if sysconfig variable is set to true

if -r /etc/sysconfig/nagios ]; then
. /etc/sysconfig/nagios
else
echo "/etc/sysconfig/nagios not found or not readable."
exit 1
fi

if x"$NAGIOS_COMPRESS_LOGFILES" = x"true" ]; then
LOGS=$(echo /var/log/nagios/archives/.log)
for f in $LOGS ; do
if -e $f ] ; then
/usr/bin/bzip2 /var/log/nagios/archives/
.log
break
fi
done
fi[/code]

I changed the value in /etc/sysconfig/nagios for compression to 'false" so that should do it.