Troublshooting Nagios/Apache2


#1

Hey all! Im new here, as if you couldnt tell. Anyway I got fed up with Zenoss which has lead me here trying out Nagios. Onto the question at hand: I have a fresh install of Ubuntu Fiesty 7.04, (worked perfectly), and after following the Nagios install instructions from [http://nagios.sourceforge.net/docs/3_0/quickstart-ubuntu.html](hyperlink url) When I attempt to browse to “http://localhost/nagios” I get nothing, basically a 404. I have verified that both Apache2 and the Nagios daemons are running…even restarted them for giggles. I recieved absolutely no errors during any of the ./configures nor the series of Makes.

Since I’ve only been using Ubuntu (or any Linux for that matter) for like a month now I have no clue where to go from here. Any help would be very appreciated.

Thanks!


#2

It’s nice to see how much traffic this site gets…

Anyway just in case anyone views this thread, I ended up totally removing both Apache and Apache2 (I didnt realize that Apache 1.3 was included with Ubuntu 7.04) which also removed Nagios. Then re-followed the quick-install guide for Ubuntu to the “T”…still no webpage at localhost/nagios not even an apache related error pages pops up. Both daemons start successfully, no errors. No erros on compile or make. The webconf worked fine…I get absolutely no errors during the install of any component. But obviously something isnt getting copied over. I have tried commenting out the use of VirtualHosts and moving the nagios/share files over into /var/www…still doesnt work.


#3

Ok with a bit of Apache2 help from a co-worker, for some reason the install process either requires a new step or possibly an existing step altered but now it works perfectly.

He copied the nagios-3.0a3/sample-config/httpd.conf file to /etc/apache2

I hope I didnt just miss that somewhere but I do not remember seeing it specified in the quick start guide.