Unable to refresh to new configuration


#1

Nagios 3.2.1 installed on OpenSUSE 11.2

  1. had nagios set up and GUI running.

  2. testing by monitoring a few https host which created from /usr/local/nagios/etc/objects/https.cfg … and added parameter cfg_file=/usr/local/nagios/etc/objects/https.cfg into nagios.cfg. Work till here so far so good!

  3. Problem starts HERE. trying to split the few host which defined in the https.cfg into afew different files,
    eg. httpsCN.cfg, httpsSG.cfg, httpsUS.cfg and etc

Excluded the parameter cfg_file=/usr/local/nagios/etc/objects/https.cfg from nagios.cfg and included new parameter:
cfg_file=/usr/local/nagios/etc/objects/httpsCN.cfg
cfg_file=/usr/local/nagios/etc/objects/httpsSG.cfg
cfg_file=/usr/local/nagios/etc/objects/httpsUS.cfg

After that the nagios GUI @localhost/nagios wont refresh to new host. Instead it keep showing the old https.cfg even though that file isnt pointed in nagios.cfg and the physical file of https.cfg is deleted.
Tried “service nagios reload, restart, stop, start”. Tried restart Apache2, clear cache, restart computer. and it still persist with the old host and not the new 1.

Double checked that the cfg_file=/usr/local/nagios/etc/objects/httpsUS.cfg and etc parameter is correctly written.

Please kindly help. Any tips on what i should do?


#2

try nagios stop, check that no nagios process is running (ps -ef | grep nagios) kill any survivors and restart. Should this fail… are you sure you are using the right server and config files? yes, this already happened, who knows :slight_smile:


#3

luca, thanks for your tips, however the problem still persist. i tried a fresh reinstall and it seems the problem occur after a certain while after the fresh install. Im wondering is it the caches or retention files causes it.


#4

what does
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg
report?


#5

Running pre-flight check on configuration data…

Checking services…
Checked 31 services.
Checking hosts…
Checked 22 hosts.
Checking host groups…
Checked 4 host groups.
Checking service groups…
Checked 0 service groups.
Checking contacts…
Checked 1 contacts.
Checking contact groups…
Checked 1 contact groups.
Checking service escalations…
Checked 0 service escalations.
Checking service dependencies…
Checked 0 service dependencies.
Checking host escalations…
Checked 0 host escalations.
Checking host dependencies…
Checked 0 host dependencies.
Checking commands…
Checked 24 commands.
Checking time periods…
Checked 5 time periods.
Checking for circular paths between hosts…
Checking for circular host and service dependencies…
Checking global event handlers…
Checking obsessive compulsive processor commands…
Checking misc settings…

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check

anyway i think the retention file mess it up… and after i change the:
retention_update_interval=0
use_retained_program_state=0

it wont cache it anymore…


#6

by the way i got another question which is, after i “service nagios reload” i found out that all my devices is in pending state and scheduled for checks but before the check happen, sometimes it declared that the device is in “DOWN” state already.

So i was wondering can i set something which can force nagios to check every single devices immediately(or near ASAP) after a reload or restart. Noted that the schedule for 1st check is about 4-5minutes after a reload/restart.


#7

if i’m not mistaken there is an option which tells nagios how much time SHOULD pass before all checks have been executed for the first time. it is NOT recommended to use these options, leave them in “smart” mode.
Service and host state retention are used normally to avoid rechecking everything, see if you can reenable some of the retention options.


#8

Firstly, ensure that the process is running Nagios and start to kill the family. If you are unsure that you use the right server and configuration files. I was wondering what may be compelled to review all equipment Nagios immediately or close ASAP after a reload or reboot. Noted that the timetable for the first review is about 4-5 minutes after charging .