Upgrade from 3.0.2 to 3.2.0 borked web server


#1

Greetings,

We have had Nagios running for at least a couple of years now, and generally speaking love the monitoring it provides. We have a bit of a hodge-podge of monitoring here (Nagios, custom Syslog, SNMP, MRTG, Zenoss,) most of it tied together and Nagios is just one part. I just upgraded Nagios to the newest version, and while Nagios itself is working just fine, the web interface got all bunged up. I’m not sure where or how, since all we did was follow the Nagios directions (recompiling, installing, etc.) and didn’t change anything at all with the web server itself. In fact, the web server is still working just fine for other services on the box.

Basically what happens is:

(1) Hit web address
(2) Prompted for login
(3) Enter login
(4) Get 403 error (You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.)

I’ve checked the Apache logs and the error log consistently shows “Directory index forbidden by Options directive: /usr/local/nagios/share/” as the only good clue. I’ve read the change log for what’s new between the version we were on and this one, and can’t seem to find anything particularly useful. All of my script directives, config files, users and permissions, groups, etc. are the same as a few hours ago when the last version worked. Obviously, I can just roll back the system (snapped on a SAN) with no problems, but I’d actually like to use this version! :slight_smile:

Any help will be appreciated!


#2

Yeah, nevermind. PhP wasn’t installed (minimalist server for security, no nothing nada if it’s not needed.) Installed that and fixed it all right up nice.