Using .htaccess with 2.0b5


#1

Hi,

Two days ago I installed version 2.0b5, and after all the configuration of the web authentication/user thing, Nagios always shows that the user “?” is logged in, not the one that I used using the .htaccess system.

Is someone having the same problem with this version? I also tried 2.0b4 with the same results… Is someone using b4 or b5 with .htaccess successfuly?

Thanks in advance for the answers…

Andres.


#2

Seems like this is a common problem with not just the beta.
grep nagios /etc/group
nagiocmd:x:502:nagios,apache
The user that the httpd runs as is apache, so change to suit.
ls -la ls -la /usr/local/nagios/share/.htaccess
-rw-r–r-- 1 nagios nagios

/etc/httpd/conf.d/nagios.conf contains
ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory “/usr/local/nagios/sbin/”>
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all

Alias /nagios/ /usr/local/nagios/share/
<Directory “/usr/local/nagios/share”>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all

/etc/httpd/conf/httpd.conf
contains
AccessFileName .htaccess

Sounds to me, that your website is ignoring .htaccess files, which is common.