Web Interface Problem


#1

I just installed Nagios onto a Ubuntu 7.10 box. The installation went good and I got 0 errors. However, when I go to localhost/nagios, I get the Index of /Nagios page. When I look down the file list I have a html folder that brings me to the Nagios web interface. When I try to click on a menu item on the left side of the page I get an error such as The requested URL /nagios/cgi-bin/status.cgi was not found on this server. Also I was never asked for a login name and password. My Nagios directory is under /var/www if that helps any.

To double check I tried the command make install-webconf again in the apache2 conf.d directory and got make: *** No rule to make target ‘install-webconf’. Stop.


#2

I also looked at my Apache2 error logs and I’m getting these errors. Where could this file be?

[Thu Jun 19 13:50:11 2008] [error] [client x.x.x.x] File does not exist: /var/www/nagios/cgi-bin, referer: x.x.x.x/nagios/html/side.html

I do have /usr/lib/cgi-bin
but nothing under that directory.


#3

Hi!

sorry, I must leave work to be on week end (at last!!) so, to be short:
you have to modify/adapt the configuration of httpd.conf of your apache server.
There is plenty of information on the internet to do that for nagios, so it should be ok (not easy, but ok :)).

post again if you didn’t manage to do it by yourself :wink:


#4

Problem Solved. Had to add some lines to my httpd.conf file. Thanks