Web login fails 2.0b2


#1

Ok so here is the issue… When I goto login I get a login prompt. I enter the username and password click ok then I get it again, and again,…
I have configured httpd.conf :
ScriptAlias /nagios/cgi-bin/ “/usr/local/nagios/sbin/”
<Directory “/usr/local/nagios/sbin/”>

SSLRequireSSL

Options ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all

Order deny,allow

Deny from all

Allow from 127.0.0.1

Alias /nagios/ “/usr/local/nagios/share/”
<Directory “/usr/local/nagios/share/”>

SSLRequireSSL

Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all

Order deny,allow

Deny from all

Allow from 127.0.0.1

I have configured the .htaccess file in both /sbin and /share folders.
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
require valid-user

II entered the user names as shown in the documentation.

I still cannot login.
I know Nagios works because if I disable security I can access all cgi scripts except cmd.cgi

Any help would be greatly appriciated.


#2

I would remove “Options None” from the Directory entry for /usr/local/nagios/share/, restart apache and try again. If that doesn’t work, redo the security entry your logging in with just to make sure you didn’t fat finger the password twice in a row - I’ve done it before :frowning: (/usr/local/apache/bin/htpasswd /usr/local/nagios/etc/htpasswd.users )


#3

The problem is that you dont have the correct rights to your htpasswd.users file. Set “chmod 777 htpasswd.users” and it will work just fine! took me almost an hour to figure out …doh


#4

The problem is that you dont have the correct rights to your htpasswd.users file. Set “chmod 777 htpasswd.users” and it will work just fine! took me almost an hour to figure out …doh