Weird Nagios problem


#1

Hi there,

I’m runnig into a weird problem and I hope someone is kind enough to help me out here. I’m kind of new into this so forgive me for the stupid things a may ask in the future :frowning:

I installed the 1.2 version of Nagios. After I ran all the things tey asked me to ad after I modified some appache config files I am able to see my start page.

But when I want to start Nagios (with the -v option) it just tells me nagios: command not found.

I think it has something to do with rights. But I’m not sure. And if so…what do I have to correct ?

Hope this info is enough.

Regards,

Peter


#2

It may help if you post the actual command you are using and "ls -l " the actual command file to check that it is there and has the correct permissions.


#3

When I do a ‘make install’ a nagios appears in the /usr/local/nagios/bin folder. A ls -l tells me that the owner is nagios with -rwxrwxr–

When I do a make install-init nothing changes.
When I do a make install-commandmode nothing changes
When I do a make install nothing changes.

But when I run the file it doesn’t seem to be there :cry:

I attached the file with the output…

When I open an other shell box…it even seems not to be there…

I run suse 9 enterprise server (Don’t know if this is a problem…).

Regards,

Peter

Edited Tue Nov 15 2005, 09:55AM ]


#4

try disabling SELinux

Luca


#5

[quote=“luca”]try disabling SELinux

Luca[/quote]


#6

Unlike DOS, most *nix boxes do NOT by default include the current directory in the search path for executables. Either use the full path name of the executable, or cd to the /usr/local/nagios/bin directory and type:
./nagios -v …/etc/nagios.cfg