Windows 7 64-bit sound in KVM Not Working


#1

I’m running Ubuntu Server 9.10 64-bit, with ubuntu desktop (Gnome) installed.
Trying to run Windows 7 Ultimate 64-bit VM in KVM.
Windows-7 installs, and comes up. Networking works. Screen works pretty well if I use the “-vga std” option.
I am using the version of KVM/QEMU that installs with Ubuntu 9.10, plus used apt-get to fetch the packages for virt-manager.
kvm --version yields "QEMU PC emulator version 0.11.0 (qemu-kvm-0.11.0)"
uname -r yields “2.6.31-14-server”.
I’m starting Windows 7 with command line:
kvm -vga std /var/lib/libvirt/images/ -boot c -m 5120

Sound does not work. Windows-7 does not detect any sound hardware.

At one point, Win 7 seemed to find a “Multimedia Controller” in Windows Device Manager. The controller was marked not working. On scanning for suitable drivers, no suitable drivers were found. Now, for some reason, Windows isn’t seeing the Multimedia Controller at all.
Per the article at:
brainmindinstrev.blogspot.com/20 … chive.html
I tried downloading the ES1370 legacy driver, but it would not install in Windows (Windows just said it was an out-of-date driver).
I also tried experimenting with -soundhw sb16, but that seemed to make no difference.

The underlying hardware is a Dell M6400 with Intel HDA chipset, CPU is Intel Core 2 Duo T9900. Sound works well in the Ubuntu 9.10 host OS in which KVM is running (e.g. can play radio channels).

I tried Googling around, but could only find requests for help on this issue, no solutions.

How do I get KVM sound working with Win7 64-bit?

Thanks!


#2

Because Windows 7 is well protected.