3-D status map w/user defined coordinates not working


#1

I have the rest of the install working, but the 3d status map keeps saying “Error: you have not supplied any 3-d drawing coordinates. Read the doc…” I have a completley working install w/these config files on a debian box, but when I transfered the configs over to the FC3 production server (what fun that was!), the 3d map doesn’t work. The FC3 install is compiled from source, using mysql for everything. I have the db set up, and it connects to it and records programstatus info etc., but for some reason doesn’t see the hostext data I have in the hostextinfo table. This db is a restore from the working debian install (whose 3d cgi worked w/my coordinates). I have commented out the xedtemplate_config_file= line in cgi.cfg, as well as made sure all the xeddb_database/xeddb_username/xeddb_database/xeddb_password are correct. I don’t have a reference to hostextinfo.cfg in the nagios.cfg file. Is there something I am missing? I have read the documentation thoroughly, but I may have missed something (or some documentation…some about mysql install was hidden in /usr/share/doc/nagios-common in debian!). Thanks.


#2

did you copy the nagios DB form one install to the other?
did you check the permissions on the DB?

Luca


#3

Thanks for the reply! I copied (exported from webmin, scp’ed it to the new server, imported it into an empty db w/the same name on the production server) the nagios DB from the working debian install to the FC3 install. I created a mysql user that was the same as the one on the debian install and set the password to the same. I checked the state retention data in the DB on the production box and it was timestamped just a few minutes ago, so it can write to the DB. It seems like nagios just doesn’t “see” the hostextinfo in the hostextinfo table. I am creating a normal text hostextinfo.cfg file and will try it with that.


#4

well, I created a quick hostextinfo.cfg file with just one host, updated all my cgi.cfg and nagios.cfg files (removed the database definitions for hostextinfo in nagios.cfg) and the host shows up. I can’t figure out why the DB method won’t work, but this will work for now. Thanks again.


#5

did you update from nagios 1 to nagios 2?
Nagios2 doesn’t use mysql anymore…

Luca


#6

no, this was a fresh compile and install of nagios 1.2. It use of mysql has been a bit confusing; it seems to write savestate data to the db, but not web interface commands. I am sure I compiled with the mysql options for everything, but it doesn’t seem to be behaving like a mysql install. I may have screwed up somewhere (i must have!) but this current setup works fine. The next thing is to stop the mysql daemon and see if nagios still works…


#7

Sounds to me, since nagios does in fact utilize the text file, that nagios was compiled to use the text file and not the db for storing 3d coordinates.
nagios.sourceforge.net/docs/1_0/xdata-db.html
./configure --with-mysql-xdata
or at least for what you want
./configure --with-mysql-extinfo


#8

Well, I must have left out the mysql-extinfo compile time option, because when I shut down the mysql server several cgi’s don’t work. I like the text file extinfo better anyways 8) .


#9

Thanks jakkedup. So it is impossible to use the textfile w/the mysql compile-time option or vice-versa? Probably a stupid question…


#10

You could find out by looking in the config.status file of your nagios source, and it will tell you how you compiled nagios.
This is from my config.status file in nagios source directory.
./configure --with-mysql-comments --with-mysql-status --with-template-extinfo --with-mysql-retention --with-template-objects --with-mysql-downtime --with-mysql-lib=/usr/lib/mysql --with-mysql-inc=/usr/include/mysql

So what did your have?


#11

it says ./configure --prefix=3D/usr/local/nagios --with-mysql-xdata --with-mysql-status --with-mysql-comments --with-mysql-extinfo --with-mysql-retention --with-mysql-downtime --with-template-extinfo --with-mysql-lib --with-mysql-inc --with-mysql-lib=/usr/l
ib/mysql --with-mysql-inc=/usr/include/mysql .

Extinfo is in there…wth!!! I guess something else was keeping it from using the mysql data (it IS in there, I checked) that worked fine on the debian box. I guess this is moot since the flat text file works fine. It is actually easier to use than the sql commands anyways. I just wish I hadn’t wasted all that time getting it to work though!


#12

wait a minute, on closer inspection I have 2 extinfo options in there. Hmm, well I guess I did screw up. Apparantley the template extinfo option takes precedence over the mysql option. I wish it had thrown an error instead of compiling. I also swear I saw that it was using the mysql option in the gcc output…