Any one in this world installed & Configured NRPE in Sol


Hi Could any can solve my issue…

I have redhat EL4 installed with nagios and my client machines are solaris i successfuly completed the NRPE installation but i don’t know how to strat daemon is there any configuration i have to do in inetd.conf

I am getting NRPE error: ssl handshake couldnot complete if run ./check_nrpe -H to y monitoring host

Please Please Please help me on this issue


ok you seem to be having a lot of trouble with this, and even more trouble understanding how inetd works, so im going to explain how to run nrpe as a daemon.

Download and untar the source code ( … 8.1.tar.gz) then run this is the directory you untarred the source to:
make all

This will make two binary files. One called ‘check_nrpe’, the other called ‘nrpe’. You need to copy the ‘nrpe’ file somewhere like /bin, or wherever you want. Copy the sample-config/ file to /etc/nrpe.cfg.

Now edit your /etc/nrpe.cfg. Going through it, you’ll see that you need to set a number of things, like the user it will run as, the group, the server port (use 5666), and ALLOWED HOSTS (!important!) set that to the IP of your redhat box. Also set up your very first check command:
add that to the bottom of the file.

Now create your first nagios check:
$ cat > /home/abishek/
echo “OMG IT WORX!”
$ chmod 0755 /home/abishek/

Now run the daemon by doing this:
/bin/nrpe -c /etc/nrpe.cfg

you can also do nrpe -n -c /etc/nrpe.cfg if you’re having troubles with SSL.

Now do a ‘netstat -pantu’ and look for NRPE, it should be listening on whatever port you defined in your /etc/nrpe.cfg.

If it’s not listening, go to your source directory and read the README file. Im going to say this again. read the README file. it tells you exactly how to do this. Also typing ‘/bin/nrpe -h’ will show you your options on how to run nrpe.

Remember, since you’re running it as a daemon, you have to restart the process every time you change your /etc/nrpe.cfg. Do yourself a favour and learn how inetd works, it tells you how to configure and use inetd for nrpe in the README file.

Compile check_nrpe here again, just like above. Don’t just copy the binary you made in solaris. Recompile here. Now use:
./check_nrpe -H x.x.x.x -c check_omg
it should return “OMG IT WORX!”



I am getting given below error if i do make

bash-2.05# make
cd ./src/; make ; cd …
gcc -g -O2 -I/usr/local/ssl/include/openssl -I/usr/local/ssl/include -DHAVE_CONFIG_H -o nrpe nrpe.c utils.c -L/usr/local/ssl/lib -lssl -lcrypto -lnsl -lsocket -liberty
nrpe.c: In function main': nrpe.c:233: warning: assignment makes pointer from integer without a cast Undefined first referenced symbol in file get_dh512 /var/tmp//cckBREzB.o ld: fatal: Symbol referencing errors. No output written to nrpe collect2: ld returned 1 exit status *** Error code 1 make: Fatal error: Command failed for targetnrpe’
Current working directory /tmp/nrp/nrpe-2.8.1/src
*** Error code 1
make: Fatal error: Command failed for target `all’


Hi I have got solaris 9 nrpe i installed on my solaris box
if i do netstat -a | grep nrpe it is listening

but i f i do ./check_nrpe -H localhost or nagios server it is through this error.

bash-2.05# ./check_nrpe -H
CHECK_NRPE: Error receiving data from host.
bash-2.05# ./check_nrpe -H localhost
CHECK_NRPE: Received 0 bytes. Are we allowed to connect to the host?