Blocked in Ubuntu installation (beginner)


#1

Hello
I have limited knowledge of Linux ; following the quick install on unbuntu (see nagios.sourceforge.net/docs/3_0/ … buntu.html) , I am blocked in step 3) when I run the command make install

18:09 root@sd-5506 ~/downloads/nagios-3.0.6# make install
cd ./base && make install
make[1]: Entering directory /root/downloads/nagios-3.0.6/base' make install-basic make[2]: Entering directory/root/downloads/nagios-3.0.6/base’
/usr/bin/install -c -m 775 -o nagios -g nagios -d /usr/local/nagios/bin
/usr/bin/install: invalid group `nagios’

Maybe I am in the wrong directeory to run the command ? the group name earlier in the installation procedure is nagcmd , is this the reason ?

I do not understand what the command Make is really about and where is the install file located if I need to modify it

Thanks in advance


#2

nagcmd is one of the groups, try creating another group called nagios with nagios user inside

[quote]On Ubuntu server edition (6.01 and possible newer versions), you will need to also add a nagios group (it’s not created by default). You should be able to skip this step on desktop editions of Ubuntu.

/usr/sbin/groupadd nagios
/usr/sbin/usermod -G nagios nagios[/quote]

I’ve done it in Debian and worked amazingly well. :wink: