Can anyone shed a little light on Nagios 2.9x on OpenSUSE 10


#1

I just rebuilt one of our servers housing Cacti and Nagios. Now that Cacti is straightened out, I’d like to reinstall Nagios. Before, I simply installed nagios (v1.3) and nagios-www, edited the config files and that was basically it.

However, instead of OpenSUSE 10.1 x64, I installed OpenSUSE 10.3 x64. It comes with the Nagios 2.9 package, but that was it. I also installed two of the plugins packages.

Anyway, I really want to use this package through SUSE so I will be able to update it via YaST. I can’t seem to find some obvious files in the default locations. One is /nagios and the other is /usr/local/nagios.

What do I have to install or configure? I have the old config files, now I just have to build it again. Your help is GREATLY appreciated. Thank you and have a great day.


#2

It’s a shame no one replied to this. Oh well, I guess I will.

After doing some research, I realized there was a Nagios-www package avilable for OpenSUSE 10.3 x64 which matches the v2.9.

Thanks for all the help. :slight_smile:


#3

sorry for the lack of answer, but I’ve always compiled nagios from the sources …
I didn’t even know there were packages :wink:


#4

It’s okay. The packages are great, especially for SUSE. SUSE has slightly different locations for certain files types. Instead of molding the OS to work with Nagios, you mold Nagios to work with your OS and I really like that part of it.

1.3 wasn’t too difficult to set up, however 2.9 has quite a few new enhancements…

I’ll post back here if I’m completely stumped. Thanks!