Cancel scheduled downtime?


#1

Nagios v. 2.06b4

I have no option to cancel scheduled downtime from the interface. Can that be right? Things I have read indicate I should be able to cancel a scheduled downtime, but the only way I can figure to do that right now is to edit var/downtime.dat, which is cumbersome.

For instance, I schedule a fixed downtime:

01-10-2006 16:02:27 (Nagios Process) This host has been scheduled for fixed downtime from 11-21-2005 15:10:57 to 11-21-2006 17:10:57. Notifications for the host will not be sent out during that time period. 928 No Scheduled Downtime N/A Delete This Comment

My right-hand menu in the server detail screen reads:

Locate host on map
Disable active checks of this host
Re-schedule the next check of this host
Submit passive check result for this host
Stop accepting passive checks for this host
Start obsessing over this host
Acknowledge this host problem
Disable notifications for this host
Delay next host notification
Schedule downtime for this host
Disable notifications for all services on this host
Enable notifications for all services on this host
Schedule a check of all services on this host
Disable checks of all services on this host
Enable checks of all services on this host
Disable event handler for this host
Disable flap detection for this host

Is this a secret configuration option, or a bug?

Thanks in advance…


#2

Are you sure that option’s missing? There should be a link called “Downtime” under “Monitoring” in the side menu of the web interface. From there you can cancel/delete scheduled downtime for any hosts/services.


#3

me too no downtime it the right pane


#4

Shot in the dark: a problem with the CGI’s when they were compiled?


#5

I don’t see any way to disable a scheduled downtime,


#6

Neither do I…what I thought was a way to disable downtime was really just a way to remove the downtime comment associated with the host.


#7

I found it.
If you clik on the service/host in question you see at the bottom the comments about the downtime.
If you hover your mouse over the little trash can, it says “Delete this comment.”

But, if you clik on the link “Downtime” in the left panel, you will see everything that has scheduled downtime.
Now, hover your mouse over the 'trash can" on bottom of page. It says “Delete/Cancel this Scheduled Downtime Entry?” I tried it, and it works.