Cannot see new hosts (?)


#1

Hi all,

After three unsuccessful weeks definitively I need your help!
Having so many good “how tos” around it is very embarrasing for me asking for your help…

I


#2

errr strange. Is minimal.cfg defined in your nagios.cfg? eg:

cfg_file=/etc/nagios/etc/minimal.cfg

You must define which config files nagios looks in for host and service definitions and all that. If it’s not that then…pretty strange. let me know


#3

Hi MP,
Thanks for your quick answer!

My nagios.cfg file is located in /etc/nagios and it looks like this:


[blockquote]cfg_file=/etc/nagios/minimal.cfg

#cfg_file=/etc/nagios/contactgroups.cfg
#cfg_file=/etc/nagios/contacts.cfg
#cfg_file=/etc/nagios/dependencies.cfg
#cfg_file=/etc/nagios/escalations.cfg
#cfg_file=/etc/nagios/hostgroups.cfg
#cfg_file=/etc/nagios/servicegroups.cfg
#cfg_file=/etc/nagios/hosts.cfg
#cfg_file=/etc/nagios/services.cfg
#cfg_file=/etc/nagios/timeperiods.cfg[/blockquote]…

And the minimal.cfg file is described above: two servers are set in there.
I also tryied using the commented out files: I commented out minimal and configured hosts, servies, etc files.
But still the same!

Now I’m still able only to see the local host in Nagios and no clue about these other servers.

BTW, I’ve lready changed from root to nagios the owner of all /libexec files (there is a similar previous entry in this forum suggesting doing this…)
But not way jose…

Is there any other place/file/whatever were telling Nagios which servers to monitor?
Or perhaps is becasue the user account I am using when starting Nagios? User: nagiosadmin, password: nagiosadmin.
nagiosadmin is the only account set in cgi.cfg file.
I dunno…

Please!
If not solution is possible shortly, my boss will decide for a paid monitoring tool (he wants to buy “SiteScope”, ut I told him wait until see Nagios working !sad )


#4

Have a look at your paths! I noticed that when you are verifying your nagios configs, the path says
/etc/nagios/bin/nagios -v /etc/nagios/etc/nagios.cfg

/etc/nagios/nagios.cfg is different from /etc/nagios/etc/nagios.cfg!!

Are you sure nagios.cfg is pointed to the correct minimal.cfg? By the sounds of it, the minimal.cfg you are updating is probably in /etc/nagios/etc/minimal.cfg, not /etc/nagios/minimal.cfg.

Please triple check your paths and get back to me. The nagios.cfg you are using to start nagios needs to have the correct cfg_file locations!


#5

Hi MP,

Thanks for you answer!!
You are right, the problem was my .cfg files and my -v check was checkin wrong files.
I’ve already changed the path…BUT I am still having the same!!

I mean, I am completely sure that all my .cfg files are located in a correct place (I’ve triple checked as you suggested) and not error reported.
But when I open nagios, only the f*** lcoalhost appears !!

Question: I believe that the problem is between Apache and Nagios and Apache is looking another files instead of the good ones.
Honestly, I don’t underestand the the entries I made in httpd.conf file, but I followed the documentation anyway.

Can you please tell me what “ScriptAlias” and the “Alias” entries mean?
What I’m doing here? What the following paths mean?

Because in all the documentations I’ve read, in all are different the paths which follows…

THANK YOU !!!


#6

If you do a nagios -s /etc/nagios/etc.nagios.cfg and it reports only 1 host in that summary, then your apache configs are not the problem. If i were you, i would move all of my configs somewhere else (ie: back them up) and start over with an example minimal.cfg and nagios.cfg. It’s somehow finding some base configs where nothing is entered, or nagios -v would result in errors

To answer your alias vs scriptalias questions anyways, i’ll give a couple of examples:
Alias /nagios "/path/to/website/files"
ScriptAlias /nagios/cgi-bin “/path/to/executable/website/files”

alias is used to tell apache that when you go to the website yournagiosip/nagios should get its files from /path/to/website/files

ScriptAlias says the exact same thing, except that the path it points to has executable cgi files in it. That tells apache it should execute the files in those directories rather that just render and display them.

In the following <Directory …> entries, you’re just telling apache who gets access to the directory, different options etc.