Can't open main config file '/root/start' for


#1

Alright, I screwed with this forever to get nagios to work, finally I got it working, thnx to some posts on this forum. It was hard for me, as before this I had little to no knowlege of linux at all. So I got apache working with php (wasn’t to hard) then mysql (that didn’t want to work right at first) anyways though, its all working. I installed nagios, go to the Whoops error when trying to run the cgi scripts on the web interface, ignored it for the time being. Installed nagiosQL, got it all working fine (even though it seemd like there documentation seemed way off… but Its working with no errors) and then I got the “Whoops!” error fixed by using the -v on the nagios binary, and sorting all that out. So there aren’t any errors at all, and I go to the webinterface, it works! But I haven’t installed any plugins yet, so it doesn’t do anything (I had it set to just ping a machine, for testing, it just read the machine as down). So I installed the plugins, and in a couple minutes it read the machine as being up, so it was working. I then seen something on here about nagiostats… I lookd at some documentation on that, tried to get it to work following This Page and didn’t get very far, but I just gave up and left it, cuz it didn’t really seem like it altered anything. Anyways I then went to add some other machines for it to just ping (I’m still very unfamilar with this, so right now I’m just doin system status) But I get all them set up, and everything looks good, I run the -v again, no errors warnings or anything, so its all good according to that, then I do /usr/local/nagios/bin/nagios restart and I get
[blockquote]Error: Cannot open main configuration file ‘root/restart’ for reading!
Nagios 2.1 Starting… (PID=28047)
Bailing out due to one or more errors encountered in the configuration files. Run nagios command line with -v opeion to verify your config before restarting. (PID=28047)[/blockquote]

The web interface still works, it just doesn’t show the other hosts yet (i’m guessing because it has to be restarted before the changes take effect) So any ideas on what I messed up? lol cuz it was working. Now its not.

Sorry bout the long post I just wanted to explain everything I did to as specific as possible. The linux distro is Ununtu btw.


#2

Also, I just went back and checked all my folder/file permissions, and I just set everything to 777 so there shouldn’t be any problems with that… This really has me confused, I will continue to see if I can dig up anything…


#3

nagios.sourceforge.net/docs/2_0/stoprestart.html

BTW, where in the docs did it say to start nagios like:
/usr/local/nagios/bin/nagios start


#4

lol wow, I feel like an idiot… i knew that, and I don’t know where the heck I read that other way, I have searched through some much stuff today, and for some reason that got stuck in my head, but thank you :smiley: I hoped it would be some stupidly simple. Now I can go on to try and further configure this to monitor more.