Caught SIGSEGV, shutting down


#1

Nagios is failing to start!

I’m using Ubuntu 8.04 x64 and I have followed the oficial ubuntu quickstart guide.

... Total Warnings: 0 Total Errors: 0 Things look okay - No serious problems were detected during the pre-flight check

cat /usr/local/nagios/var/nagios.log

[1251472293] Nagios 3.2.0 starting... (PID=19828) [1251472293] Local time is Fri Aug 28 16:11:33 WEST 2009 [1251472293] LOG VERSION: 2.0 [1251472293] Finished daemonizing... (New PID=19829) [1251472293] Caught SIGSEGV, shutting down...

I’m able to access the web interface although there is not a running nagios process!

what can I do to solve this issue?


#2

It seems there is a bug with some Ubuntu versions and nagios…


#3

I have exactly the same problem with Ubuntu 10.04.1 and Nagios 3.2.1.

Did you ever find a fix?

TIA


#4

Installing from RPM or from source?


#5

I installed from source using the Quick Start Installation Guide.

The installation went without incident.

Tested using: /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

The result is no errors, no warnings.

When I attempt to start the daemon using /etc/init.d/nagios start, nothing happens. ps -ef | grep nagios gets only one response, that for the grep.

I’ve also attempted to start the daemon with /etc/init.d/nagios start. Same result.

The browser opens and the front page is displayed, but when I double click on hosts or services I get this error message:

Whoops!

Error: Could not read host and service status information!

The most common cause of this error message (especially for new users), is the fact that Nagios is not actually running. If Nagios is indeed not running, this is a normal error message. It simply indicates that the CGIs could not obtain the current status of hosts and services that are being monitored. If you’ve just installed things, make sure you read the documentation on starting Nagios.

Some other things you should check in order to resolve this error include:

  1. Check the Nagios log file for messages relating to startup or status data errors.
  2. Always verify configuration options using the -v command-line option before starting or restarting Nagios!

Make sure you read the documentation on installing, configuring and running Nagios thoroughly before continuing. If all else fails, try sending a message to one of the mailing lists. More information can be found at nagios.org.

I’ve read the documentation and find no mention of this behavior.

I’ve rebooted and attempted to restart the daemons multiple times. I’ve had this same behavior on two different Ubuntu 10.04.1 machines.

Over the weekend I built an entirely new Ubuntu 10.04.1 machine, installed Nagios 3.2.0 and it ran perfectly.

Art


#6

Sorry no idea. I don’t get why it should work on one and not on the other… i suppose the different ubuntu machines have the same kernels?


#7

Actually, one is a 64 bit kernel, 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 x86_64 GNU/Linux,
and the other two are identical 32 bit kernels. The 64 bit and one of the 32 bit kernels don’t work and the other 32 bit kernel works.

One other difference, the 32 bit machine that works didn’t have apache2 installed. So I installed it as part of the Quick install process. The two machines that don’t work, both had apache2 already installed. They had been updated to the current release, but they had been previously installed.

The machine that worked had fresh everything, including the Ubuntu 10.04.1 install.

I don’t understand why that would make a difference, but it’s the only difference I’m aware of.

Thanks for your help,

Art


#8

i don’t think apache should make a difference… i don’t even think it’s a prerequisite for nagios in itself at compilation time.

What if you move the compiled executable from the “good” to the “crashing” 32bit machine?


#9

I have the exact same problem on a Ubuntu 10.04 Server 64. I don’t know how to fix it. I double checked the configuration and the permissions.
[1279731790] Local time is Wed Jul 21 13:03:10 EDT 2010
[1279731790] LOG VERSION: 2.0
[1279731790] Finished daemonizing… (New PID=2270)
[1279731790] Caught SIGSEGV, shutting down…

I don’t know how to fix it.

any help??


#10

Same problem here: Ubuntu 32 bit - installed from the repos, nothing works…

I think we will have to start thinking about a manual install… does anyone wknow a very explained and detailed how-to about this?

I have been half the day dealing with this problem… please!!!


#11

Crap! I installed it, and configured it from scratch from sources… it has been working until now…

Same scenario: Ubuntu 10.04 - but this time, installed from source…

Please… anyone has any solution?? This is driving me a bit mad already… i have been configuring it carefully for the last 2 days…