Centreon front end generates incompatible commands for monit


Hi all,

Sorry for this crosspost, but I realised my question is more beloning in this topic.

I ran into a rather complicated issue for me using centreon as a front end for nagios (It was recommended to use centreon in this forum somewhere ). I thank you already for reading my little story .

I started out with just nagios and everything worked fine , monitoring windows servers with nsclient etc. In the windows.cfg file I had commands like to check cpu load:

define service{
use generic-service
host_name hostname…
service_description CPU Load
check_command check_nt!CPULOAD!-l 5,80,90

Then I started using centreon which can auto generate these commands . I use the predefined command check_cpu_nt to have a similar check. This contains the following code :

$USER1$/check_nt -H $HOSTADDRESS$ -v CPULOAD -s “public” -l 2,90,95

However when I use this command (nagios verify =ok), I get a “connection refused” in the monitoring overview!
When I look at the generated command it shows something different in the services.cfg file:

define service{
host_name hostnames
service_description check cpu
is_volatile 1
check_command check_nt_cpu
max_check_attempts 5

contact_groups Systeembeheer
stalking_options o,w,u,c

I thought to be smart then, so I created a new command :
and then added the rest of the command as an argument in the centreon argument field:
!CPULOAD!-l 5,80,90

The end result in the nagios config file is the same like the sample. Sounds good you may think.
However this results in the following error:

check_nt: Could not parse arguments

How can I get this to work again? Am I overlooking something?

using nagios 3.0.2, centreon

Many thanks &
Best regards