Changed IP of a host and Nagios still reports old IP in aler


#1

Hello,

I had a typo when I added two hosts to my Nagios hosts.cfg file and therefore I was getting timeouts when the plugin tried to run. I changed those IP addresses to their correct values and I am still getting this same timeout. I can ping each of the hosts using the “check_ping” plugin with the options specified in my checkcommands.cfg file and get responses with ~5 seconds so I shouldn’t be hitting the 10 second timeout.

When I get alerts for the hosts being down it reports the old IP address and not the new corrected IP address. I have restarted nagios after I made the changes and even removed the hosts from the config and readded them after a restart of nagios and I am still getting the same behavior.

The “check_ping” command is working no problem for all the other hosts.

Any ideas??

Oh using latest nagios cvs and plugin 1.4.2 and running on Fedora Core4


#2

Personally, I think you still have nagios running. Make sure it’s dead with ps -ef|grep nagios.


#3

O.o…looks like you got it right. I thought just restarting nagios would do it but it looks like a process was staying active.

Thanks again :slight_smile:


#4

Well, I figure if I answer 100 topics, that I’m bound to get 2 of them right. So you got lucky, hehe.


#5

NEVER EVER use the RESTART option in nagios…
at least NOT from the web interface…

“bad” * things happen when you do :smiley:

Luca

*: For a reference about the true meaning of “bad” please see the movie Ghostbusters… :smiley: