check_disk problems -- please help


#1

I am running check_disk 1.64 , nagios-plugins-1.4.3. I am seeing incorrect results for free disk space and the perf data is also wrong. I am running the check_disk on Redhat ES, centos machines. Is anybody seeing the same problem.

[root@caitmon plugins]# ./check_disk -w 20% -c 10% -p /data
DISK OK - free space: /data 17652 MB (95% inode=100%);| /data=1025MB;14941;16809;99;18677
[root@caitmon plugins]# df -h /data
Filesystem Size Used Avail Use% Mounted on
/dev/sda10 19G 77M 18G 1% /data

I think the 1.3 versions of plugins used to use df -pk and they seem to be reporting the results correctly.

thanks

I


#2

I have the same problem with disk_chek. Have you fixed it? If so how.


#3

downgrade your check plugin. Mine works.


#4

I’m running RH EL4. There is no down grade path. Any other reccomendatios?


#5

Dont really matter what os you are using. downgrade the plugin.


#6

I have downgraded the check_disk plugin and still the same results. When I runn the plugin from the commad line it retuns.

/usr/lib/nagios/plugins/check_disk -w 20 -c 10 -p /home

DISK OK - free space: /home 255 MB (13%);| /home=1729MB;1964;1974;0;1984

obviously the disk is not ok. No matter which plugin i use i get the same results. Any thoughts?


#7

/usr/lib/nagios/plugins/check_disk -w 20 -c 10 -p /home
Try looking at /usr/lib/nagios/plugins/check_disk --help.
It tells you that if you use an integer like 20, then that means 20 MB must be all that is left, until you get a warning. So, from your defintion, you want a warning when there is 20MB or less, and a critical if there is 10MB or less. So the plugin output is NOT wrong.