check_iftraffic3.pl but no output - RESOLVED


#1

Good evening all;

I’m using the check_iftraffic3.pl plugin to get stats off the interfaces. It has been working really well.

I just got a few servers that when running the command;

/usr/local/nagios/libexec/check_iftraffic3.pl -H localhost -i eth0 -u m -I 1000000000

it gives no output. I have to ctrl-c to get back to the shell prompt. This is happening when I run it locally on the monitored machine or have it being run from the nagios server to the monitored machine. I have the perl SNMP module loaded ok, I’m just not sure what I’m missing.

Is there a list of pre-requisites for check_iftraffic3.pl anywhere?

TIA,

Bill


#2

Ok, so much for assuming… :roll:

SNMP is now installed. Now when running the command line it comes right back to the shell prompt but still no output. I verified the proper permissions are there, proper mode755. Making headway, I guess.

Any thoughts, ideas, suggestions?

TIA,

Bill


#3

This issue is resolved.

On the Linux systems;

ensured SNMP is loaded
changed owner on all files in /usr/local/nagios to nagios:nagios
made sure any /tmp/traffic* files were owned by nagios

On Solaris systems;

ditto SNMP - had to add Net-SNMP-v6.0.0 to the Sol10 servers
ditto on the ownerships