CHECK_NRPE: Error - Could not complete SSL handshake


#1

Hi,

I get this error when I run the procedure to install nrpe, and i am following the documentation below.

nagios.sourceforge.net/docs/nrpe/NRPE.pdf url.

I get the error below, when i try to supress the SSL with -n option.

/usr/local/nagios/libexec/check_nrpe -n -H localhost

CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.


#2

this error may have several reasons:

  1. the easiest: did you add your nagios server IP in the allowed_host line of your nrpe.cfg file ?

  2. did you compile your nrpe and check_nrpe with the -ssl-enabled option ? if yes, you shouldn’t use the -n option (both executables have to use the same encryption).

  3. if you don’t really mind about security, re-compile both executables without ssl; it might work better

  4. And last one I can see: (It happened to me). The nrpe executable is not able to find the required librairies. Check it with this command: “ldd nrpe”; all the librairies should be present …
    If one of them is not found, you’ll have to implement it, or recompile or add it to the LD_LIBRARY_PATH variable.

I hope this helped you :slight_smile:


#3

I’ve come across this many times, due to our NFS mounted /usr/local. The configure script finds the ssl libs in /usr/local/lib, before /usr/lib. And /usr/local/lib is not in any of the ld.so.conf directives. I’ve gone so far as to remove the /usr/local/lib search directive from all Nagios related configure scripts to avoid this.
Make sure that the libraries you are linking to at compile time are available at runtime. As mentioned by Loose setting the LD_LIBRARY_PATH will help if the ssl libraries are not found in any of the ld.so.conf.d/*] path(s).

Don