CHECK_NRPE: Error receiving data from daemon


#1

This is probably a case of missing the obvious but i have tried everything i could think of and also what the nrpe.pdf doc suggests. :cry:

I am installing nrpe on centOS box using yum. The package installs without error.
Verion info: nagios-nrpe x86_64 2.12-1.el5.rf

I’ve added the check_nrpe command to /etc/nagios/objects/commands.cfg

‘check_nrpe’ command definition

define command {
command_name check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDRESS$ -c $ARG1$
}

and the host IP address to nrpe.cfg

nrpe is configured to run as a daemon and shows as running:
ps auxw | grep nrpe
root 26257 0.0 0.0 61164 692 pts/3 S+ 13:43 0:00 grep nrpe
nagios 29589 0.0 0.0 39968 1084 ? Ss 13:18 0:00 nrpe -c /etc/nagios/nrpe.cfg -d

nrpe is listening on the correct port:
netstat -at | grep nrpe
tcp 0 0 mail.panoston.com:nrpe : LISTEN

The problem(s) arise when I run check_nrpe on the remote host.
Running without ssl yields
/usr/lib64/nagios/plugins/check_nrpe -H Remote IP address -n
CHECK_NRPE: Error receiving data from daemon.

Running with ssl yields:
/usr/lib64/nagios/plugins/check_nrpe -H 192.168.2.231
CHECK_NRPE: Error - Could not complete SSL handshake.

The only thing I haven’t tried is compiling from source using ./configure --enable-ssl. I assume yum will make the ssl option available on installation.

Any suggestions would be appreciated.

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group


#2

Problem has been solved. Several set up errors and a malfunctioning firewall. System is working normally.


#3

Can you explain what the setup errors were and the firewall issue? I’m having exactly the same problem at this point and can’t for the life of me figure it out.