Check_SIP plugin


#1

I am trying to use the Check_sip plugin from www.bashton.com (seems to be the common one to use). I am having two problems however.

The first is this: When I run the command

check_sip -u uri@example.com -H some.ip.address -p 5060 -w 2

from the command line, it works fine, and returns with an OK response. When I type that very same line into my checkcommands.cfg file, Nagios reports the status as 'No Output".

The second problem that I am having is when I run that same command using a different SIP server, it returns the error, “Invalid Extension”.

Does anybody have any experience with the check_sip plugin that may be of some help?


#2

I found my problem. I originally suspected that it was a permissions problem; however, I did execute the command as my nagios user prior to submitting this thread.

Upon further investigation, I concluded that the nagios user did not have the utils.pm in it’s include path. When I logged in and ran the command as my nagios user, I happened to have already changed into my plugins directory, so it ran it from there. I added the location of this file to my include path, and it now works fine.

This appears to have solved both problems, though I’m kind of stumped as to why it would have anything to do with my 2nd problem.


#3

hi,

anybody tried this plug-in? what does -u means? does the -H refer to the ip of the sip device or the proxy server?

thanks


#4

anybody else tried this plug-in?


#5

Can you elaborate on this ? I too have the same problem !

I made the pluging run by changing the command line to “cd $USER1$ ; $USER1$/…”, it still reports no output but seems to accept the check as OK - I guess it returns 0 as a result code even if no output makes it back to nagios.


#6

Doh !
it was so damn simple, all it needs is a simple change to one line of perl code. Edit check_sip and change
use lib “/usr/lib/nagios/plugins”;
to
use lib “/usr/local/nagios/libexec”;
(or whatever your installation path it).