check_snmp missing


#1

Hi everyone,

I’m brand new to Nagios and here is what I have done and the problem I am having.
First, I used the Quickstart Installation Guides to install Nagios. Version nagios-3.0.6.tar.gz and nagios-plugins-1.4.13.tar.gz
And used the Fedora Quickstart procedure since that is my linux flavor.

After the install here is what I did.
Know problem getting localhost to show up on the web gui. WOW it works!
Ok, on to configure my first windows box. Followed quick start guide, made config changes. It works! Can’t believe it, on to the next devices I want to look at.
Monitoring Routers and Switches. Ok followed quick start guide made changes to nagios.cfg and switch.cfg. Go back to GUI and refresh, can’t believe it my first switch is listed! This is to easy. Wait, whats this, errors.

ProCurve S1

PING OK 03-15-2009 13:39:39 2d 23h 50m 11s 1/3 PING OK - Packet loss = 0%, RTA = 1.92 ms
Port 1 Bandwidth Usage UNKNOWN 03-15-2009 13:34:42 2d 23h 49m 8s 3/3 check_mrtgtraf: Unable to open MRTG log file
Port 1 Link Status CRITICAL 03-15-2009 13:35:44 2d 23h 48m 6s 3/3 (Return code of 127 is out of bounds - plugin may be missing)
Uptime CRITICAL 03-15-2009 13:36:47 2d 23h 47m 3s 3/3 (Return code of 127 is out of bounds - plugin may be missing)

Hmm. I think the problem is “check_snmp” since it is missing under “/usr/local/nagios/libexec” directory.
I look and look for documentation how to install the missing file but can’t find it?

So this leads to my problem, how do I get this file on to my box. Please no replies “just download the plugin” If you can tell me what plugin and how to install it that would be greatly appreciated. I have been reading this forum and looked on the nagios website but cant find what I need to get it working. Or is it another problem?

Thanks,
Rick


#2

Hi

check_snmp is part of the nagios-plugins but it won’t compile it if you don’t have net-snmp, as indicated in the REQUIREMENTS file included with nagios-plugins…

[quote][root@localhost nagios-plugins-1.4.11]# cat REQUIREMENTS
Nagios Plugin Requirements

Some plugins require that you have additional programs and/or
libraries installed on your system before they can be used. Plugins
that are dependent on other programs/libraries that are missing are
usually not compiled. Requirements for various plugins are listed
below…

check_snmp:
- Requires the NET-SNMP package available from
net-snmp.sourceforge.net/

.[/quote]

Install net-snmp and recompile the plugins, then you should have check_snmp.

HTH

/S


#3

Exellent tip, of course you couldn’t tell me how to install snmp that would be to easy. So after some digging I used “apt-get install snmp” command with my ubuntu flavor. This seems to have worked.
Now if I can just get this last error resolved. “check_mrtgtraf: Unable to open MRTG log file”

Update: After a little investigating I notice “check_local_mrtgtraf” is missing from the /usr/local/nagios/libexec directory.
This must be causing the problem but I don’t know how to fix it.

Rick


#4

For
crying
out
loud…

the link to net-snmp.sourceforge.net is right there in my post. Did I reply with “just download the plugin” ? No. I told you what you needed to do… showed you the excerpt from the REQUIREMENTS doc… explained that you’d need to subsequently recompile the plugins… All documentation including downloading, instalaltion and configuration instructions is there on that page…
What? You want me to read it out loud for you? Hey, no problem. Hold on, let me get my crystal ball out and ascertain if you’d like instructions on installing the package from source, or yum, or apt, or whatever. Better still, you want me to pop round and install it for you? Hey, why don’t I do that right now, all free of charge of course!

Whatever you do, don’t say thanks. Hell no… Just carry on being sarcastic and then go on and ask for more help! I’m certain someone else will reply, your demeanor is just so condusive I’m sure people will bend over backwards to assist you… I’ll guarantee you this though, it won’t be me.

Don’t bother replying to this 'cos I ain’t going to read it… People like you really get my goat and I really couldn’t care less whether you get it working or not anymore.


#5

Hi Strides,

I had the same problem as the one above, your answer got it solved. Thanks for that!

grtz

Goldie


#6

Hi Strides or anyone else

Do you by any chance have some experience with the following error?
I get it when trying to load a MIBs file (which is already placed in the default mibsDIR where net-snmp loads them):

[quote] administrator@S-LAM-01:~/.snmp/mibs$ sudo snmptranslate -m +LEFTHAND-NETWORKS-GLOBAL-REG-MIB
snmptranslate: error while loading shared libraries: libnetsnmp.so.25: cannot open shared object file: No such file or directory
[/quote]

I do not know if this question is really in place here, but I think it does (I’m configuring Nagios :slight_smile: )

Thanks in advance!

Grtz!

Goldie


#7

it looks like libsnmp is missing… check your RPM manager.


#8

Hi Luca,

thank you very much for your fast response.
It is working now, libsnmp was already installed.
I just did an ldconfig and now things are ok concerning that error.

However I have another problem now with net-snmp not loading my HP-LefthandMibs I have placed in the default mibs-dir, but I’ll do some googling first …

Thanks Luca!