check_snmp still missing from libexec


I cannot get check_snmp to appear in my libexec.

Currently running Nagios 3.0.6 on Ubuntu desktop 9.0.4. Did a successful Nagios install from the quickstart guide. When I do apt-get install snmp snmpd, everything looks good. No packages to install or update. I also installed Net-SNMP from, which was successful. I also downloaded and successfully installed nagios-snmp-plugins using the synaptic package manager. When I reconfigure the nagios plugins 1.4.13, I see in the output: net::SNMP perl module found, checks made for snmpget and snmpgetnext.

Libexec still doesn’t have check_snmp, yet I see check_mrtg and check_mrtgtraf, which according to other posts require the same prerequisites as check_snmp.

Does anyone know what I am missing?


are you compiling the plugins or installing them through apt?


I am recompiling them using the quickstart guide directions for configure, then make and make install


check for warnings in the configure output.



I did. There is no error or warning message related to check_snmp. In addition, I have another test machine where I did a brand new install with nagios 3.1.2 and nagios-plugins-1.4.11. Same thing, successful install but after adding net-snmp- from source and then libnet-snmp-perl from synaptic package manager, I get same results. No check_snmp plugin.

There are no errors when I reconfigure the plugin related to SNMP. It finds the net snmp perl modules and the snmpget and snmpgetnext modules.


not sure if it may help but the latest plugins are at version 1.4.13


I tried though as well. I think everything is in place in my setup for the check_snmp plugin to be successful. There must be a problem with the ./configure and ubuntu.

Is there a way I can manually create check_snmp from the .c module or some other way?


not sure if this applies:



I have resolved the issue on both my machines.

On my second test machine, I noticed that the net-snmp- got an error at the end of configure, missing lperl. So I installed several perl modules and then configured net-snmp successfully, after that I reconfigured the 1.4.11 plugins followed by make and make install. Finally, the check_snmp appeared.

The packages I installed were (in this order)

  1. sudo apt-get install libperl-dev
  2. sudo apt-get install libnet-snmp-perl
  3. sudo apt-get install libsnmp-session-perl
  4. downloaded net-snmp- from, then ./configure, make and finally make install

after that, downloaded nagios-plugins-1.4.11.tar.gz from, followed by
sudo tar xvzf nagios-plugins-1.4.11.tar.gz
cd nagios-plugins-1.4.11
sudo ./configure --with-nagios-user=nagiois --with-nagios-group=nagios
sudo make
sudo make install

The other machine had nagios-plugins-1.4.13 installed. There was an issue with check_http and I think the install bailed out when it hit that error and did not process the rest of the plugins, including check_snmp. I could not resolve that error so I backed up to nagios-plugins-1.4.11 and had success.

This procedure worked successfully today. As time goes by and versions of packages get updated, it will likely be obsolete. The key was to force myslef to look carefully at all the output of each step and figure out what the warnings and errors meant in terms of a final result.

Nagios has been quite a hard dance to learn.


happy it worked in the end :slight_smile: