check_snmp with SNMP Version 3 username


#1

I’ve tried to find this information everywhere, but no luck so far.
I need to use check_snmp with a switch that uses SNMPv3 and a user login. Using snmpwalk I can access all of the MIBs correctly with the username entered. However, check_snmp doesn’t seem to have an option for that.
I found this post (I can’t recall the URL offhand) that mentioned using [email protected] for the community in check_snmp, but that didn’t work either.

Any ideas?


#2

use snmp v3 as in the check_snmp docs:

nagiosplugins.org/man/check_snmp


#3

I tried that first. It keeps failing, saying “invalid option, -P” or “invalid option, -U”, or “unrecognized option --secname”, etc.

When I run ./check_snmp -V it returns
"check_snmp 1.4"


#4

Tried re-downloading the plugin and now it gives me those options–don’t know how I got a different one.

Still having trouble though. If I use the -U or --secname function, it yells at me, saying
"External command error: snmpget: No securityName specified"

The docs don’t seem to be much help here…what am I missing?


#5

no idea. i just checked the docs and saw the v3 commands… but i can’t check it.