check_tcp problem

Hi all,

I am using Nagios 3rc1 on Ubuntu 7.10. I’m a fairly novice user but have found the product easy to use and configure.

I have one problem with check_tcp that I have been unable to resolve. When I run the plugin from the command line it works ok:

[email protected]:/usr/local/nagios/libexec# ./check_tcp -H xxxxxxxx -p 3389
TCP OK - 0.014 second response time on port 3389|time=0.013579s;;;0.000000;10.000000

However, when I try to use the check_tcp for the hosts check_command the plugin returns the following error:

check_tcp: Port must be a positive integer

The paramters used are exactly the same as those on the command line:

check_command check_tcp!xxxxxxxx!3389

Is it possible to use this plugin for a hosts check_command?


Did you ever sort this out? I’m having the same issue.

(Sorry for not just responding here in the first place and creating a new thread)

Solved the issue.

I have included N parameter as well

like eg:

/usr/local/nagios/libexec/check_tcp -p 3127 -H -N hello

1 Like

Yes… I had the same problem. After Including the N parameter.It works well
Thanks sreejesh