Code 127


#1

hello all!

This is about new install (nagios2 on Fedora).

I have an error (Return code of 127 is out of bounds - plugin may be missing) in the Status Information column for all service checks and No Output under Host details.

I can run checks manually, they run well at command line.


#2

I’ve seen that with cfg files copied from a different server. I never figured out the problem though


#3

Have you confirmed at command line as user nagios?


#4

It’s most likely that you have a configuration problem.
For example:
In my resource.cfg I have this:
$USER1$=/usr/local/nagios/libexec
In my checkcommands.cfg I have this:

‘check_tcp’ command definition

define command{
command_name check_tcp
command_line $USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$
}

Now, if I actually have my check commands in the directory:
/usr/libexec or some such nonsense place, then I would get the same error as you have.

Also, if I had incorrect permissions on the files, then to the user nagios, those files will never be found.

So check your configs and file/folder permissions again, and make sure you can run them by hand.
su - nagios
./check_tcp …


#5

I had a similar problem, but a specific set of steps to reproduce. I could start okay with /etc/init.d/nagios start. No errors reported. I could restart with /etc/init.d/nagios restart. No errors reported. If i tried /etc/init.d/nagios reload - ALL services would report failure with same message as reported in this thread. thoughts? i do not know much about -HUP.


#6

tks jakkedup, was my resurse.cfg!