Compiling 1.4.13 plugins on Solaris 10 - no check_swap


#1

Hi,

I have successfully compiled nagios plugins 1.4.13 on a Solaris server and noticed that the check_swap script was not created under /usr/local/nagios/libexec. I Googled and found that Solaris does not support floorf and followed instructions (or so I thought) on various workarounds but nothing seems to work. I have tried the following:

Edited the …/nagios-plugins-1.4.13/plugins/common.h file and added the following:

#if defined(__sun) || defined(sun)
static inline float floorf (float x) { return floor
(x); }
#endif

I then ran make clean, my configure command (configure --without-mysql), make, make install. Everything works fine but the check_swap script still does not get created.

I also edited the …/nagios-plugins-1.4.13/plugins/check_swap.c file and changed both instances of floorf to floor. I ran make clean, my configure command, make, make install. Again, everything worked fine but no check_swap script. Any ideas on what I can do to get this fixed?

Thanks for any help provided,
Jon


#2

Already discussed, you could try to serach the forum first :slight_smile:

viewtopic.php?f=59&t=1689&hilit=check_swap