Configuration error at Startup


#1

When I run nagios -v nagios.cvg if get:

Reading configuration data…

Error: Command ‘check-host-alive’ has already been defined
Error: Could not register command (config file ‘/opt/lampp/etc/minimal.cfg’, starting on line 75)

***> One or more problems was encountered while processing the config files…

 Check your configuration file(s) to ensure that they contain valid
 directives and data defintions.  If you are upgrading from a previous
 version of Nagios, you should be aware that some variables/definitions
 may have been removed or modified in this version.  Make sure to read
 the HTML documentation regarding the config files, as well as the
 'Whats New' section to find out what has changed.

I can’t locate the command to remove a command ( tried delete, remove undefine ).

Anyone know how to correct this ?

Magnaman


#2

Huh???
I suggest you do as it states, it states to read the docs.
nagios.sourceforge.net/docs/1_0/toc.html
and for heavens sake, don’t be running the delete command and NOT know what you are doing, otherwise, you will end up with a linux install with no files on the hard drive.


#3

Hahahahahahaha, yeah, don’t try to run around deleting junk without knowing what you’re doing. You SHOULD go read the docs, but I you should also READ the errors you’re getting. Your “check-host-alive” command in minimal.cfg has been specified already…think about it…


#4

The other thing is, that I can tell you are attempting to install the beta, since you are having this minimal.cfg problem and duplicate whatever error. I too had that, and you will have alot more little things wrong that you will need to fix. So, bottom line is DONT install the beta. Install a rock solid v1.??? that doesn’t have these little problems and be done with it. Once you become an expert in nagios, then and only then should you install the beta’s. REason I say this is, that you are going to have to many little things wrong with the beta, you will become frustrated and may think nagios is junk, when it’s not. So, install v 1.x and be happy and problem free.