Error adding new device


#1

Hi, I’m a new user of NAV, I’m currently using NAV installed on a FreeBSD 5.4-STABLE, when I tried to start NAV, there wasn’t any problem, everything seem to be ok. The web interface hadworked either.

The main problem is when I tried to add a new device (a 7200 cisco router) it was always been an error like this :
"Error : “none type” object has no attribute "lstrip’

I had follow the instruction correctly, to add the database successively from their dependencies.

Could anyone help me with this?
I would really appreciate any kind of help

thx


#2

query the router for oid .1.3.6.1.2.1.1.2.0 (sysObjectID).
/usr/bin/snmpget -t 1 -r 5 -m ‘’ -v 1 -c public xx.xx.xx.xx:161 .1.3.6.1.2.1.1.2.0

The value returned will be something like
iso.3.6.1.2.1.1.2.0 = OID: iso.3.6.1.4.1.45.3.35.1

Plug the value 1.3.6.1.4.1.45.3.35.1 into the Sysobjectid field in the add new type to database. Take note of the lack of a period in the value. It’s 1.3.6.1.4.1.45.3.35.1 and not .1.3.6.1.4.1.45.3.35.1

That’s about all that I have found out with this nav so far.


#3

I have also try to add the Sysobjectid, but the problem remains the same. This is the complete error :

Error: exceptions.AttributeError: ‘NoneType’ object has no attribute ‘lstrip’