Error: Could not read object configuration data! - Need help


#1

I am fairly new to Linux and Nagios.

I installed Nagios on Debian Etch using this tutorial:
netmonitoring.org/nagios/ins … th-apache/

I modified the tutorial to use the latest version of Nagios and NagiosPlugins though.

I am able to bring Nagios up in the browser and log in, but when I try to click any of the options in the menu on the left I get the following error:

Error: Could not read object configuration data!

Here are some things you should check in order to resolve this error:

  1. Verify configuration options using the -v command-line option to check for errors.
  2. Check the Nagios log file for messages relating to startup or status data errors.

I did not know how to verify my configuration so I did a search in the forums and found the command:
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

I ran this command and it returned 0 errors and 0 warnings.

My Nagios.log file has no errors in it either.

Does anyone have any other idea where else I should look for the problem?

Sincerely,
Shannon


#2

I think I may have found the problem.

It seems Nagios was not running.

I ran the following command ( ps -ef|grep nagios ) from this Thread:
meulie.net/portal_plugins/fo … p?400.post

and nothing was returned so I manually started Nagios:
/usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg

Everything seems to working now. :slight_smile: