Error on printer status


hello everyone,
i installed nagios 3.2.3 with nagios plugins 1.4.15 on ubuntu 10.04 and it working correctly, then i tried to moniter some network printers so i installed snmpd on the server after that , i edited on nagios.cfg and on the printers.cfg to accept the new printer, so i went to ipaddress/nagios ->services i got this error on printer status "Error in packet : Timeout from host "
the printer name is kyocera 5300
can anyone help me


does the printer respond to snmp requests? does it work from command line with snmpwalk ?


thank you for reply,

i think the printer respond, when i type this command

snmpwalk -Os -c public -v 1

i got a large screen output, Does that mean it respond :roll:

thanks again,


If that is the printer IP address yes :slight_smile:


yes, the printer ip and i tried to restart it but nothing changed



this is my printer status for SNMP , do i need to change something
help me

SNMPv1/v2c: On

Read Community: public




HP Web Jetadmin Compatibility: Off

Authentication Traps: Off


if the printer responded to snmpwalk you have to find the data you want back from it… it’s all in that response. Find the correct OID and modify your check_smp command accordingly.