Extended Host Definitions


#1

Hi,

I’ve setup about 3 or so nagios boxes (for various companies) and i’m trying to setup another however I am having some real problems.

Each box is running Fedora Core 3 or 4 and installed using EXACTLY the same list of commands (instructions) using EXACTLY the same versions of all the components. Ive tried using Nagios 1.3 and 2.0 each has this same problem.

The extended host definitions just will not work. Ive been onto this for 3 solid days and have got nowhere with getting Nagios to compile with the extended host definitions.

This is what i’m compiling with:
./configure --prefix=/usr/local/nagios --with-cgiurl=/nagios/cgi-bin --with-htmurl=/nagios/ --with-nagios-user=nagios --with-nagios-group=nagios --with-command-group=nagcmd --with-gd-lib=/usr/local/lib --with-gd-inc=/usr/local/include --with-template-extinfo

Then whenever I try to add an extended host definition into an external file they are ignored. If i add them into the hosts.cfg (which is how I did it on all the previous boxes i’ve built and works fine) i get this:

Error: Invalid hostextinfo object directive ‘host_group’.
Error: Could not add object property in file ‘/usr/local/nagios/etc/hosts.cfg’ on line 47.

Has anybody got any ideas at all i’m really at the end of my tether here!

Thanks


#2

What’s on line 47 then?

“Error: Invalid hostextinfo object directive ‘host_group’”. Do I interpret this correctly if I say that you are trying to define the host_group in the extended info template? According to the Nagios HTML docs a Extended Host Template has the following elements:

define hostextinfo
{
host_name
notes_url
icon_image
icon_image_alt
vrml_image
statusmap_image
2d_coords
3d_coords
}
Might that be it? I’m new to Nagios, so I’m absolutly unsure about this… :?


#3

Hi,

Sorry I was being dumb, I saw that shortly after so I fixed it.

Still didnt work so I recompiled again, then suddenly the extended host definitions started working, So whatever it was it sorted itself.

On a slighly different topic, has anyone got Fedora Core 4, Apache 2.0.55 and Nagios 2.0 working?

When it starts it works fine, but after a reboot, or restart of the Nagios daemon it has 20 - 30 nagios processes running and then gets in a right mess and stops checking hosts.

ps axu | grep nagios
Shows:
nagios 11149 0.2 1.0 868 488 ? S Feb 27 6:33 /usr/local/nagios/bin/nagios nagios.cfg

and then

nagios httpd - nagios :shock:

Any ideas?

Thanks