Extended Info


#1

Hey all.

New to the forums here but just had a quick question about extended information. I’ve been fiddling with this now for a bit but no matter what I try, nothing will appear on the status maps. I know I’m missing something but I can’t put my finger on it. Running v1.2 and no matter how many different images and coordinates I put for a host, it never changes from the standard status map.

I know once i
Any help is appreciated and let me know if there is other info that is needed.


#2

Wow dunno how this got posted so many times. If a mod could delete the others I would appreciate it.

Thanks


#3

When you view the status map, there is a selector box named “Layout Method:” in the top right of screen. click the drop down, and select “User-supplied coords”, then clik the UPdate button right next to it.


#4

tried it and it came back with “you have not supplied and host drawing coord” I’ve setup a exthostinfo.cfg following the template-layout method and changed the cgi.cfg to use this file.


#5

It’s probably not being used due to it failing a verify.
So verify it.
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg


#6

It’s probably not being used due to it failing a verify.
So verify it.
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Try it with this layout. Just change somehostname to a real hostname. Do NOT put any other hosts/definitions in your file. The below should be THE ONLY ONE. Keep a copy of the one that you are making of course.

define hostextinfo {
host_name somehostname
icon_image unknown.gif
gd2_image
2d_coords 2370,1025


#7

nope, nothign failed during pre-flight. No errors and or warnings. Is it possible that I’m missing a default folder that needs to get changed? I’m assuming it just can’t find the file.

edit: Tried your suggestion and again got the same response. To me it’s not even seeing the file hense my comment above.


#8

nagios.cfg has definitions that state what files to use. This must match exactly the location/name of your file. My nagios.cfg has this:
/usr/local/nagios/etc/hostextinfo.cfg
Yours may and can be a different name/location.
It must have proper permissions.
Permissions are:
ls -la /usr/local/nagios/etc/hostextinfo.cfg
-rw-r–r-- 1 nagios nagios 39843 Apr 24 14:12 /usr/local/nagios/etc/hostextinfo.cfg

I suspect, that you have not defined the cfg file in nagios.cfg as I have done above.


#9

Ahh that was the problem. It had been commented out of the nagios.cfg config for some reason.

It still doesn’t compile now but at least it’s seeing the file.

Thanks :slight_smile: